站长网 大数据 hdoj 1002 A + B Problem II 大数

hdoj 1002 A + B Problem II 大数

A + B Problem II Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 302658????Accepted Submission(s): 58410 Problem Description I have a very simple problem for you. Given two integer

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 302658????Accepted Submission(s): 58410

Problem Description

I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.

?

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

?

Output

For each test case,you should output two lines. The first line is “Case #:”,# means the number of the test case. The second line is the an equation “A + B = Sum”,Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

?

Sample Input

  
  
   
   2
1 2
112233445566778899 998877665544332211
  
  

?

Sample Output

  
  
   
   Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 2222222222222221110
  
  

?

Author

Ignatius.L

?

Recommend

We have carefully selected several similar problems for you:??
1004?
1003?
1008?
1009?
1020

import java.util.*;//输入的库
import java.math.*;//大数时用的库
import java.io.*;
public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
     Scanner in = new Scanner(System.in);
     BigInteger a;//大数标准定义格式
     BigInteger b;
     int n,i;
     n=in.nextInt();
     for(i=1;i<=n;i++)
     {
    	 a=in.nextBigInteger();
    	 b=in.nextBigInteger();
    	 System.out.println("Case "+i+":");
    	 System.out.println(a +" + "+b +" = "+a.add(b));
    	 if(i!=n)
    	 System.out.println();
    	 
    	 
     }
	}

}

本文来自网络,不代表站长网立场,转载请注明出处:https://www.tzzz.com.cn/html/shuju/2021/0527/6978.html

作者: dawei

【声明】:站长网内容转载自互联网,其相关言论仅代表作者个人观点绝非权威,不代表本站立场。如您发现内容存在版权问题,请提交相关链接至邮箱:bqsm@foxmail.com,我们将及时予以处理。
联系我们

联系我们

0577-28828765

在线咨询: QQ交谈

邮箱: xwei067@foxmail.com

工作时间:周一至周五,9:00-17:30,节假日休息

返回顶部